Please help (IMPORTANT)

Hello guys , i want to say that i am the guy who is crashing the servers when i join . I realised it yesterday when i connected with other 2 players and after 5 - 6 sec it crashed . You will tell me that it is the host 's fault but it's wrong . So i ask you to tell me a solution for this problem because i want to play sometime seriously without these crashes above my head .

Saint , you remember that you told me in our xfire chat that i must download a new version of the swat 4 TSS . So ... my answer is that it won't change anything , cause it's my IP's fault and i will spend 1 hour for the installation again and for the nothing that it will happen with this new version .

For you guys that you have something in your mind please post it here or contact me when i will be online in the xfire or you can send me a PM and i will see it when i will log in here .

If a guy here came face to face :cry: with this problem or someone helped him and he still remembers the solution please tell me step by step by TEAMVIEWER 6 - 7 or write it tome me in an xfire chat .

I want to take my job back which job is the reports and checking our new applicants . If the server keeps crashing i won't be able to do these things and of course i don't won't to quit playing this game cause of this stupid problem .

Also , if you guys have ANYTHING to say about the problem and this << something >> it will be wrong i will try it on my game and i will tell you if it worked or not .

I will do anything to have my game back to normal .

Detective
Image
I doubt it's your PC that crashes the servers. Happened to me few times and to others aswell. Sometimes server crashes and restarts by itself real quick and sometimes it completely stops.
I have to test it but... the program made by Hunter, the "Join PRO server" by SK could cause the issue. Don't ask how and why I don't know myself, that's why I will test it.
I believe SK's fast join button on old site isn't working properly because I used it 2 times and I noticed server crashed real fast (it didn't stop, just crashed) both times.
"You might think you know everything there is to know about me.. But really, you're not even close."

"I don't care if this is the end...So...I'll use everything."
Alright then , test it and tell me if you have time
Image
The only thing that can crash a 1.2 Server is joining with some files in your TSS game that are still 1.0 I think. A guy from America used to join VOWS server he also had correct version 1.2, but his version of the patch didn't over ride or create new files properly. So my advice. Uninstall, and make sure to use UK patch not French or German or anything else. Also make sure the patch is the real TSS patch and not a re-packed patch, NOTE: The re-packed 1.2 patch works and looks 100% just like the normal real patch so telling the difference is hard, one way to make sure is to download the PATCH with a new TSS game. AUTO-INSTALLER always uses real patches..

If this don't work and somehow it's your IP causing crashes because of some reason one thing to do is IP masking.. Hide your IP from the server engine.
or IP changer, pretend your from another country to trick the server. None of this works then my friend I have nothing else. I've never really seen anyone with this problem b4, sept like I said people connecting to 1.2 servers with old version. Another way around is maybe delete your system folder in TSS and ask someone to send to you on Xfire.

EDIT (Wed Sep 26, 2012 6:48 pm):
And I forgot to say that in some country's having XFIRE open and transmitting server information can cause you to crash. Xfire lags out in some parts of the world and by doing so mess's with your server sent packages etc.. blah. So Try playing without Xfire running. Bugs man. Think people would think of a way to 100% Test programs now before release it's 2012 ffs lolz. Also Xfire auto update can crash or lag your server connection if signed in as Admin maybe this is messing with the server settings from GezMod or MarkMod somehow with like I said messing with server sent information. Turn all the shit off and play only TSS with nothing running.
Image
And I forgot to say that in some country's having XFIRE open and transmitting server information can cause you to crash. Xfire lags out in some parts of the world and by doing so mess's with your server sent packages etc.. blah. So Try playing without Xfire running. Bugs man. Think people would think of a way to 100% Test programs now before release it's 2012 ffs lolz. Also Xfire auto update can crash or lag your server connection if signed in as Admin maybe this is messing with the server settings from GezMod or MarkMod somehow with like I said messing with server sent information. Turn all the shit off and play only TSS with nothing running.
Image
Guys, at first we must make one big difference between SERVER and USER issue. As far as we are talking about our PRO server, keep on finding USER issue is meaningless. Just like Sokol said, the PRO server stops and restarts itself even though there is no one playing. That's the reason we are going to refuse rackage.com host for our servers.

In case we are talking about our normal server (as we probably do) that is hosted on MarkMods.com (and that should be 100% working), we need to decide where is this issue regarding to (USER or SERVER). Actually we have few theories, let me comment them and let me add my one as well.

1. Detective's theory (he causes the server crash)
I'm pretty sure it has nothing to do with your IP. IP is just number, nothing that would cause the crash. True, crash might come in case your IP Address is banned (when it's wrongly reported in Swat4XDedicatedServer.ini). The thing that could cause some crash is your network connection -> BUT! -> While you have issues with network connection YOU would crash, not the server. So I would find Detectives theory as unlikely.

2. Sokol's theory (direct button and my program causes the crash)
No Sokol. Let me show you how everything works.

Direct button -> When you click to "Join the PRO Server" button, your browser will open this URL address: xfire:join?game=swat4tss&server=193.93.47.91:10484&password=**** -> When browser open this URL, your browser will send message to Xfire with parameter that cointains URL address above -> Right after Xfire receive this parameter message, Xfire will start Swat4X.exe with this parameter 193.93.47.91:10484?password=**** and Swat4X.exe is running on it's own (even if Xfire shutdown, game will run)

My program -> When you click to "Join server", program will "load to memory" IP address, port and pass that you filled out to 'Child Window' -> From IP and server it will make a parameter %IP%:%PORT%?password=%PASSWORD%, so in case of PRO Server, it would be 193.93.47.91:10484?password=**** -> Then it will run Swat4X.exe with this parameter and Swat4X.exe is running on it's own (even if program shutdown, game will run)

As you could see, both "ways" just start Swat4X.exe and it's running on it's own. It means it can not ever be button's or my program's fault. Running game with parameter will just make you able to join server directly and game isn't loading things like Menu, Single Player, Quick mission player and things like that. If game would load something wrong, it would cause the game crash (so you would crash, not the server). It's same as "shortcut" for direct connect that I added to our forum into Recruit section. It works pretty same.

Shortcut -> When you run shortcut, system windows will start Swat4.exe with parameter that you have set to *.ink file (shortcut file). Then game running on it's own, but true, when Windows shutdown, you are not going be able to keep playing xD, but still.. you would crash, not server.

That's why I would also find this theory as unlikely.

3. Andy's theory
That's most trustworthy theory (at least one part) from all here stated . I pretty much agree with your theory about file version issue. This really might cause the SERVER crash. I think detective should for sure try your way. It could be helpful indeed.

Second part isn't so good as your first one Andy. Xfire also run the game with parameter, but it can not cause the server crash (ofc imo). Xfire gathers information about server independently on Swat4X.exe process. It loads information about server, but you don't need to play Swat4X.exe or so.. basically Xfire still does. The only different that is made when your game is running is, that it make information about server visible in your status line. By 'make them visible' I have on mind that Xfire already has those information, if not, Xfire gathers them from Server IP Address directly, it doesn't use Swat4X.exe process to gather info. Also Xfire doesn't communicate with Admin Mod in game. About Xfire bugs, it can cause crash, but only on your side. You will crash, server will not.

3. My theory
Even though I think Andy has great point in file version issue, there might be something else to think about. Members can not notice it, but we (SA's, CL and CM) can. I'm talking about our local ban list that is saved in Swat4XDedicatedServer.ini. It's huge one, can have about 150 lines. I think, while MarkMods Admin Mod loads 150 lines every time when someone connects, it might overload memory imo. Also, if we have some incorrect report saved there, and when someone with similar IP connects, MarkMods memory overloads and there we go.
Since we have Online Ban-lists working again, I would try to give them full trust. Delete (temporary remove) ban list from local list, disallow "SaveBansLocaly" in server settings and try to live on online ban lists.

Hunter
Image

Code high, commit sober.
Then I guess it was just a bizzare coincidence that server crashed 2 times in a row after I used SK's image for joining. Will test tomorrow for sure.
And yeah, I know how that stuff works Hunter. :) I'm just stating what I've experienced.
"You might think you know everything there is to know about me.. But really, you're not even close."

"I don't care if this is the end...So...I'll use everything."
The huge ban list I didn't think about, too much information for swat to load per map changed, per server restart.. maybe makes it slow? even crash.
I'm not sure how it all works I'm not a PC wizard but I think we should also have someone go through out (BAN List) delete all old bans that are from a long time ago.
Try to cut down the info sent and maybe this could help. Why have 150 bans when half are from 2 years ago or 6 months ago, worth a try I guess.

Also one thing I noticed in-game with admin rights for years I've used admin panel in-game whenever you change map from server settings, change something making someone respawn, or even changing the Server start/Finish clock can crash the server. No one should ever use in-game admin to do any kind of server settings at all. First because people always forget to press update server ini or something like this, forgot what it says.. everytime u use admin stuff the server kind of try's to remember it for the log but if u don't do it correctly even smallest settings wont save in INI file and when server loads next.. it will try to find even smallest server change and if not saved it will crash - rstart - lag sometimes even just turn it's self off all together. Maybe I'm wrong but this is just experience I have in many servers for years.
Image
Sokol wrote:
Then I guess it was just a bizzare coincidence that server crashed 2 times in a row after I used SK's image for joining. Will test tomorrow for sure.

Hunter wrote:
As far as we are talking about our PRO server, keep on finding USER issue is meaningless. Just like Sokol said, the PRO server stops and restarts itself even though there is no one playing.

So, I wanted to say that you don't need to keep looking for button bug, because PRO server isn't stable itself. ;)
Image

Code high, commit sober.
lol i downloaded another version of the game and it has 3 files , idk where to start :roll: . If someone is able to help me via teamviewer it will be my pleasure :P
Image
Fear no more, Sokol is here! All your problems will go away in no time. :D

I'll be on xfire in few mins.
"You might think you know everything there is to know about me.. But really, you're not even close."

"I don't care if this is the end...So...I'll use everything."
I also had that problem.Then i downloded another setup of Swat 4 then it worked.
Dont use pirate links dude
Image
Sorry for that :D
Pirate links are not welcome here. Altough I've talked with SK before and he said it is not a problem if we do post them. But still..

I've tried to help detective to install the game. We were successful but one very annoying issue appeared. He had all letters bolded in-game. The font was weird. That same thing happened to me before but I fixed it with reinstall, unfortunately reinstall didn't help detective.
And we used the same link you wrote earlier, Mohit.
"You might think you know everything there is to know about me.. But really, you're not even close."

"I don't care if this is the end...So...I'll use everything."

Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 5 minutes)
Most users ever online was 196 on Fri Nov 23, 2012 8:34 pm

Users browsing this forum: No registered users and 1 guest