[Solved] SWAT 4 getting stuck during startup

Heyho,

So last week I tried to start up TSS. Everything went fine until the screen turned black. After that it just stayed black for minutes, no main page in sight. Same problem with Vanilla even after restarting the PC. Today I finally found the time to reinstall Vanilla but to no avail - It still gets stuck on the black screen for 5+ mins and now it seems to be even worse, before reinstalling SWAT I could at least get back to desktop by starting up TaskManager (I almost wrote TaskyManager :lol: ) but now I got a complete hang-up, nothing moved at all.

Does anyone have an idea what could be wrong?
Some people just need a high five.

In the face.

With a chair!

:obscene-birdiered:
Excluding damaged hardware and keeping only software issues in mind:

1) Missing files?
2) Compatibility mode?
3) Have you installed/uninstalled anything recently?
4) Try running in windowed mode
5) Check swat4.ini file, maybe you are using unsupported resolution?
6) Get rid of game movies, check if it helps
OK now things are starting to get funny: I tried running vanilla with the settings for Win XP SP3 and it worked. However resolution was 800x600, when I changed it to 1600x1200 (I used that on both vanilla and TSS before, worked completely flawless) settings said it was set to 1600x1200 however it was still in 800x600. My guess is that something with the resolution got screwed up, I'll check it out when I got time for it and tell you the results, so it would be nice if you could leave this thread open for now. Thanks for your help xyzzy.
Some people just need a high five.

In the face.

With a chair!

:obscene-birdiered:
Is there any sound while you have the black screen (for instance the ambient background noise on the main menu or intro trailer)? If that's the case, then it's probably something with the resolution yeah.. Try using 'alt + enter' to make your game windowed (as Xyzzy said) and see if that does anything in this case. Never had this issue before myself, but I always run my programs as administrator.. Probably won't change anything but worth a try! :)
If you see the woman with the shotgun, kill him! ~ |ETS|TaskForce141
SWAT 4 can ignore changes you are trying to make when you don't "run as administrator", same case with the 'SWAT 4 Toolkit'.

Toolkit did no effect until I ran it as administrator, changed things, then ran the game as administrator. Finally worked.
Changing to a custom resolution did not work either until I ran the game as administrator and got the resolution I wanted.

If you haven't started the game as administrator before then I'd advise you to try it.
Hmm no, I don't hear any sound at all. And running SWAT 4 as admin has always been de rigeur for me :)
It could also be something with the system, prior to reinstallation I used a fixed exe with both vanilla and TSS, now using fixed exe results in system error, says it can't hook into the process or something like that....
I should notice that I had something similar on my old (Windows 7 Prof) laptop, first the sound disappeared and later it wouldn't start up at all.

Thank you all for sharing your advice, I'll try to solve the problem once I got time and nerves for it.

HP
Some people just need a high five.

In the face.

With a chair!

:obscene-birdiered:
Hellpatrol wrote:I almost wrote TaskyManager :lol:
:lol: :D

hey HP .. did you update your sound and graphic driver to lastest version ? ( + try to reinstall DirecX 9.0 or 10 and Nvidia Physx ) ..


and if it doesnt work i will send you a link to download it again :D

regards
There's a clocktower in Hereford where the names of the dead are inscribed.
We try to honor their deeds even as their faces fade from our memory

Call Of Duty Modern Warfare 3
Hellpatrol wrote:
Sun Aug 20, 2017 6:26 pm
It could also be something with the system, prior to reinstallation I used a fixed exe with both vanilla and TSS, now using fixed exe results in system error, says it can't hook into the process or something like that....
So I assume you're using a cracked copy, right? If so then explain the installation process and I'll see if you made an error somewhere by any chance.
Ragdoll wrote:So I assume you're using a cracked copy, right? If so then explain the installation process and I'll see if you made an error somewhere by any chance.
Yes and no, I'm using a retail version but a fixed .exe was mounted into system folder by me so I don't have to insert the CD everytime.
Situation now is that SWAT 4 vanilla runs flawless when being started by CD, only remaining issue is that I can't get a better resolution than 800x600 but that's really nothing more than a bump in the road for me - as long as my system still grants me the fun and enjoyment of playing some COOP with you everything's good :)

EDIT: OK, NOW it starts to get ridiculous :D : I just installed TSS, ran it (again via CD) and it works fine too. Now I can even set it to any resolution I want - As if nothing has ever been wrong :lol:
I have seriously no idea what the issue was but apparently it has been fixed.

:text-thankyoublue:
Some people just need a high five.

In the face.

With a chair!

:obscene-birdiered:
Holy chair! Solves all the problems. :D

Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 5 minutes)
Most users ever online was 196 on Fri Nov 23, 2012 8:34 pm

Users browsing this forum: No registered users and 1 guest